pbaba
侠客
侠客
  • 最后登录2021-06-16
  • 发帖数2
阅读:390回复:0

[前端][H5] 使用了 Taro.xxx 的组件都会出现 _xxx is not defined 错误(3.0.0)

楼主#
更多 发布于:2021-05-07 13:16
H5使用了 taro UI中的图片选择组件(AtImagePicker) 报错(_chooseImage is not defined
不关是上传,还是删除 等方法都会报  xxxxx is not defined
注:[3.0.0][H5] 使用了 Taro.xxx 的组件都会出现 _xxx is not defined 错误
在网上找了很久,发现是  


原因看转载网址:https://github.com/NervJS/taro-ui/issues/1178


只有临时解决的办法:在node_modules中找打tora-ui(3.0.0)文件中的package.json 文件添加一个入口

  1. "main:h5": "dist/index.esm.js",
让 taro 把 index.esm.js 作为 taro-ui 的入口即可。

最新喜欢:

doubleyongdouble...
游客


返回顶部

公众号

公众号