doubleyong
管理员
管理员
  • 最后登录2024-06-25
  • 发帖数1175
  • 最爱沙发
  • 喜欢达人
  • 原创写手
  • 社区居民
  • 忠实会员
阅读:1084回复:0

[nodejs]Can‘t find Python executable “python2.7“, you can set the PYTHON env variable.解决办法

楼主#
更多 发布于:2024-02-27 16:22
问题 :


使用npm install 安装模块时,报错如下:


Can‘t find Python executable “python2.7“, you can set the PYTHON env variable.解决办法





解决思路: 看到这个错误,第一反应是想,也没有用python呢, 不是python 项目。为啥会提示这个信息呢?


然后,还是跟着信息去找了对应的信息方案, 下载模块,配置相应的环境变量,但还是报错;


最后,想着还有一个警告,node-sass 与 sass-.load 不兼容的问题,先把它解决了; 结束解决了sass的兼容性后,上面的错误也奇迹般的好了。




解决方案:


修改了其它bug 后,这个bug 好了;
 修改的是 node-sass 与 sass-load的兼容性




总结 :
给了解决bug 的另一种思路; 如果某一个bug 走不通时,先把其它的bug 解决了。哈哈
知识需要管理,知识需要分享
游客


返回顶部

公众号

公众号